Back to overview
Downtime

Beta Dashboard not accessible

Feb 26, 2026 at 5:34pm UTC
Affected services
Dashboard (beta-app.pilotflows.com)

Resolved
Feb 27, 2026 at 6:09am UTC

We’re back! BETA Dashboard should be up and running. Thanks for bearing with us.

Created
Feb 26, 2026 at 5:34pm UTC

The BETA Dashboard (beta-app.pilotflows.com) is currently unavailable and redirects all users to the main app (app.pilotflows.com).
This is expected behavior following a scheduled update that was deployed at midnight. The team is actively working on the issue and we expect the BETA Dashboard to be fully restored within the next few hours.
We apologize for the inconvenience and thank you for your patience.